Start a new topic

Erae lab detection problems

The Erae Lab no longer detects the Touch surface on my main DAW PC. I am able to get it to work on my laptop.

I have tried everything with unplugging, restarting, reinstalling. I have removed the device in windows setting, under USB devices (which is how I got it to work on my laptop) but on my other computer nothing works. I have tried different usb cables, different connections to the pc. 

I am using Windows 10 on both computers, all updated etc...

All my other devices work. 

I am glad I can still get it to work with my laptop, but this is highly unpractical and kills my workflow besides the fact that the laptop is my work device.

Any help would be appreciated because I am quite frustrated right now.

Thank you.

1 person has this problem

Hi Guillaume, 

Did you maybe try solution like this:

> Windows assigns the driver for MIDI devices by USB port, it is possible to exceed 10 registered MIDI devices even if you have not connected that many unique devices. 


indeed using this utility I am way over 10. I do see my Korg drivers (since I have 2) and 20 others. So removing all that is not really a solution, but looking into the thread, I tried to adapt the method to the Erae. However, in the registry I don't know where to find the drivers to replicate the workaround. Would you be able to help? Like what is the name of the erae driver?

Sadly, not sure if I can help with changing the registry manually. I was under the impression you could uninstall several devices (presuming they can be installed again) and thus free up slot for erae? (which now i dont think its the case with erae)

If the device is working on another machine, then its probably usb device drivers on your desktop machine.

check cables and ports one more time. 
check and update all your relevant motherboard drivers (particular usb related ones) and restart.

Hope it helps. 

Also very important, does your desktop machine has something in startup that takes over your midi connection to devices. If so, you will not be able to connect from Lab (or DAW) to erae.

I'm going to continue investigating the issue and report. I must precise that the erase is seen by Ableton as a USB device or any stand alone vst, labeled correctly. It's only with the lab software. Also under windows 10 desktop, it is seen. It shows as USB composite device. There's no exclamation point under device driver. It also used to work. Would you know what the erae driver name is? Is there a setting I can save to the erae when the device is connected to the laptop?

On Windows OS there is exclusivity issue with accessing any particular MIDI device. 
If DAW is first to connect to Erae Touch and then you start LAB software, LAB will not be able to connect to device. At least from what i understand.

the only way to have the both (Lab and DAW) is a solution i mentioned here

ps i dont know the name of the erae driver name (as seen by registry)

When I use a daw, I make sure not to use the lab, as I'm too painfully aware of windows limitation. I just indicated that out is recognized in windows, as a reference to troubleshoot. Thank you.

You are welcome,
sorry to re-state the obvious.

So I was able to bring the Erae to be within the first 10 midi devices in windows, but that is not resolving the issue FYI.

I'll look at the start up as a possible cause.

Is there anyway to access older erae software and firmware?

Login or Signup to post a comment