Start a new topic

I can't use the "Erae Touch Midi (MPE)" Input in Cubase Pro 12

Hello Guys,

My Erae Touch just arrived, and I can't use the "Erae Touch Midi (MPE)" Input in Cubase.

MacBook Air M1

Ventura 13.1

Cubase Pro 12.0.52 Build 393 (Apple Silicon)

Erae Lab V.1.3.0

Kind regards




I've downloaded also the new Ableton 11 Trial Version and did all your recommendations 

“Setting Up Your ERAE Touch in Ableton Live“ 

with the same result. MPE doesn't work!







I've  now tried it all, even some advices from youtubers, which own one. Here's one I tried:

Traum Haft Do you have a arturia plugin ? If yes open it in standalone mode. Click on settings on top left corner and enable Erae touch MPE. On the plugin click on the tool at the top right corner and enable mpe. On your Erae touch, the default layout is a normal midi, so click on alt to enter mpe mode. Hit one key of the 'virtual' keyboard layout on the erae then push the Fa clef on the erae (first button) for one second to make sure you are in mpe mode. if it's written MPE o back to your layout and play. Is it working ?

That doesn't worked either.

I am willing to exchange my unit, for a new one, instead of a refund, because now I am certainly sure, that my unit seems to be not working correctly.

Today I should have a video call with them, but I found the right settings myself before the call. It was my mistake. I did't understood the concept with mpe split and the alt button. Now it makes sense.

And also:

As I've read in the forum, that there are only 10 guys running the company, I understood the delay in communications with them.

Login or Signup to post a comment