Start a new topic


Hello, i'm trying to follow the process shown here:

with Pigments inside FL Studio.

When i try to play notes on the new layout, nothing happens.

- loaded new layout onto Area fine

- set Pigments to use the ET Pigments Explorer  as Midi Config file

- Arae connected and plays notes elsewhere (with default layouts), ie. Midi working between Arae and DAW

- sequencer (Alt) in new layout works fine

- other Midi devices work fine w/ Pigments (Pigments Midi channel set to All)

Any suggestions whats wrong?  Thanks in advance!  great product!

I have hit the same problem  that you have, though in my case I am using Cubase Pro 12. I noticed that some things like it better running when using them as a VST vs standalone, but but with pigments 4 neither has worked yet for me. It almost look like the CC messages simply are not going anywhere when using the provided layout.

Question, are you routing MIDI over USB like I am? I'm doing two things next: 1. placing a MIDI sniffer in-line to capture ALL traffic so I can see what is or is not actually going on, and 2. I am going to try using the hardware MIDI on the device rather than MIDI over USB to see if it makes any difference.

I will report back my findings; likewise if you ended up solving this, please let me know what you did!

hey there, thanks for the reply!  I'm just using basic midi over USB to a PC.

Let me know what you figure out; esp. if doing hardware MIDI makes a difference.

anyone from EMODME care to comment?  Please?

Hey guys, I’ve attached a file, if you go to the preferences of your Pigments, do you have the aware boxes ticked off? I Know that was a hold up for me
I can be dumb and forget to attach files. Apologies :)

@Fitzy thanks for the added perspective! I'm not running it direct typically and am loading it as a VST through Cubase 12 Pro, but the same concept. While this was not my problem, you inspired me to give it another go this morning to see if I could get to the bottom of it. I am posting a little bit early because I have not identified all of the different ways that this goes sideways for me, but I figured I'd put it out there and update later. So, I was able to narrow down my particular problem to EraeLab. Specifically when I load up lab, or have it already loaded, or something in between, the act of the Lab entering the Mix (ha! pun not intended, but I'm rollin' with it anyway) things cease to play nicely and my already fragile MIDI house of cards comes crumbling down. I also have a K-Board Pro 4, and in their workflow having the controller tool open while in "use" is a positive thing so you can tweak live. Being used to that workflow, I was just always keeping Lab up in a similar fashion, and it looks like that little habit ended up causing this behavior for me.

So, I'm gonna play a bit more and see exactly what scenarios are breaking it, but it's enough of them that it pretty much never worked for me without really isolating it first. The weird thing is, I don't see why having it loaded is so disruptive, unless maybe they are relying solely on MIDI command and control messages for configuration etc. rather than having an abstracted layer for that stuff when on USB. It's nice to actually have MIDI AND the MPE messages both hitting pigments, at the same time, finally! :)

Will check  back in as I try to narrow things down a bit more to specific action/reaction behaviors.

I have been unable to solve this issue. Pigments explorer works great when using the standalone vst. 

The only DAW I have had absolute success with, is Bitwig. I can say that I have successfully gotten the layout to function as intended.

The issue that I ran into with all other DAWs is how the era is presented on the midi end. On this layout, the keyboard is MPE, but all of the controls are standard midi. In order for you to get the layout to work, you have to listen to "All" midi inputs. This absolutely is not useful in a studio environment with multiple midi inputs being recorded across multiple pieces of gear.

Selecting the Midi input only listens to the controls, selecting the MPE listens to the keyboard. So, you have to find a way to listen to both at the same time, while still isolating it from other inputs. 

For Bitwig, that's easy. There is a script located here:

I deleted the erae controller out of my settings in Bitwig, then created a new controller with the vendor of "accSone" and assigned the erae MPE and Midi outputs as the new controller input. This aggregated the Erae midi streams into one selectable controller input and now everything functions flawlessly.

When I attempted to use the midi 2.0 setting in logic, as soon as the MPE keyboard was touched, it crashed pigments 100% of the time.

Hopefully there is something available for your DAW of choice, but this just cemented Bitwig as my main DAW.

sorry, here is the script link lmao

Oh, and in regards to the OP's specific keyboard issue on the layout, FL studio doesn't support MPE. I believe their goal is to support midi 2.0 rather than implement MPE.

Hey Elk,

I tried to follow what you said here I downloaded the files from github, I dont see the controller in bitwigs list, do i need to run the js file or somerthing? this is not working for me. I cant get pigments to control like in the video , so frustrating, every single piece of hardware i get just doesnt work, or only works in ableton or whatever....and no one from Embodme ever responds? they wont make a script for bitwig?

Hey Stephen!

Sorry for the delay, I was recording an artist at the studio yesterday.

For the Bitwig script, you should open up your Bitwig settings, navigate to "controllers" and drag + drop the files onto the controller setting page.

Once that has been completed, create a new controller, and in the "Hardware Vendor" list, there should be an entry for Embodme, within that menu it will show Erae Touch. Select that and a controller will populate with  2 midi outputs and 1 midi input.

If the Erae is hooked up and communicating properly (open Erae lab to verify), the I/O can be assigned from the dropdown list.

Assign Erae touch Midi, and Erae Touch MPE to the outputs, and the Erae Touch midi on the input.

Hopefully that gets you up and running.

Down the road, if you are looking to combine the MPE and Midi streams into one pipeline, there is another script available that can merge both the midi and MPE streams.

and in terms of Embodme's customer support or community interactions, I wouldn't hold your breath. There has been no indication that this product is actually being supported outside of a vague statement that a firmware update was supposed to be released 2 months ago, that information is 4-6 months old.

Login or Signup to post a comment