Start a new topic

midi trs: type A or type B

it just mentions 'trs' in the manual, as far as i could tell. I wasn't getting midi output from the midi port, and at this point i'm not sure of the cause (maybe i had my midi trs adapters mislabeled), but then also there was stuff that i didn't see in the docs about the mac audio midi setup - just saw it here in the forum.

I want to whine about this a bit. The docs are pretty bad.

Some of it might be translation issues, but for instance, i'll look up specific things and they don't seem to be documented clearly - especially the erae lab software. I think that maybe documenting all of the settings/fields by name would help? and CLEAR explanations as to what some of the commands do? the online help for the preview mode? I don't understand it. and there were others. I suppose it's fine if the default modes work, but if you're troubleshooting, it's hard to know what you're doing.

but my situation was complicated by the fact that although I JUST got a new touch a couple of days ago, the firmware was something like 1.11. I mean, wtf?

in any case - i found in the forum just now a discussion about how you need to delete the icon in the mac audio midi setup and then reconnect the touch. I mean - how many hours did i spend struggling with issues related to this, using ableton live?

in any case - embodme isn't alone in underestimating the effect of bad documentation. But this has been extremely frustrating. i had basically given up on using mpe at all, but i think that maybe resetting the audio midi setup might get me further. Admittedly i want to get this to work with a somewhat complicated routing, but if embodme can comment on this issue in the forum, they can put it in the manual.

Hi Nelson,

We will be improving the documentation so everyone can find more specific answer about the features available and troubleshooting in the various scenarios.

The MIDI TRS is type A, which is the MIDI standard. The TRS issues have been fix since the 1.2.3 update, if you find any new ones please let us know.

As far as Erae Lab goes, you already have a lot of information in the Learn section of the Erae Lab software. You can find it in the lower left corner. When you hover over an item, the description of each parameter and elements appear. We will add new informations with each update. If there is any information missing in this section you can inform us as well and we will add it.

Regarding the firmware version you receive, it should not have been 1.1. But as we are constantly working on new versions, it is perfectly normal that when you receive the product it does not have the latest update. In fact, the last update we released was not available when we sent your product. So it is normal to have to update it after you receive it, this is true for any hardware that can be updated.

We will add the midi audio configuration to the documentation so people don't have to waste time like you did, we are sorry about that.

As always, if you have a problem that you can't solve, contact us by ticket or directly on the forum, if a problem is still not solved after our exchange, you can contact me at to schedule a video call and see in more detail what your problem is.


just a note that i did get 1.11 a few days ago in my new Touch, when 1.2 has been available for quite some time. So, no, that is not 'perfectly normal'. 

Login or Signup to post a comment