Start a new topic

Button not activated after pressing (mapping ableton)

I just can't wrap my head around it.
I mapped a button (not latched) to activate a track.

If it's activated / deactivated out of ableton, the feedback on the Erae touch is instant.
But if I press the Erae button, it flashes briefly while hitting it, but it does not correspond to the track activation status.

Any help with the setting?


I'm getting a similar problem. I want to use the buttons to trigger buttons on/off on my Deluge, but I have to press them twice to toggle off. If I use Note objects it works but the Notes don't give visual feedback of whether the button is on or off.

I'm sure all these little tweaks will get sorted eventually.

1 person likes this

What are the setting of your button?
Latched settings you need to press more then once for activation state.
Normally one would disable latching.

When I press the activation/deactivation in my DAW (ableton) the feedback seems to work,

so there is some internal (software) issue preventing it from lighting up I guess.

I've tried all the settings but I'll let you know a little later when I'm back at my gear.

I understand that latching will keep the button lit, which it does, and when I press it once it activates my Deluge track, but to deactivate my Deluge track I have to press the button twice, which means it unlatches and then latches again, showing a lit state both for on and off.

Ideally I need a button that is only a toggle, so press it once to activate my Deluge track, the button remains lit (but not latched), then press the button again to de-activate my Deluge track which also turns the lit state off. Like a hybrid of a note and button element.

I think the latched button is for things like holding a note down or triggering a latch button on a synth, which is not what you want for triggering tracks, but I guess we are trying to do it this way because there is no other way to do it! (yet).

The thing with latch buttons is that they send 2 types of midi info.
Once activated and once deactivated. I'll test this tonight as ableton can show the exact midi signal.

But what we need is the same midi signal for activating and deactivating, the signal send back to the erae seems disrupted by the input itself, for some reason. I'll do a deep dive tonight.

Odd this isn't discussed elsewhere. This seems a very basic function and I browsed all available video and haven't seen a single button behaving this way, only where a latched button plays a bass drone.

Well be damned, while latching the button does show when activated but needs 2 presses to deactivate.
Strange behaviour indeed :)

Hey guys,

Thanks for posting in the forum. Can you send us a minimal Ableton live session that replicates that bug, and .emk file that you use? So we can replicate the scenario in our studio and figure what you have issues with.

Generally, to our knowledge ableton live is designed to only work with non-latched buttons.


1 person likes this

I have put a zipfile with an ableton live11 project.
Simply mapped the 2 buttons (latched deactivated) to the 2 tracks (mute/activation)

As you will see, the buttons on the erae respond if you click these buttons in ableton.
But not when you press them from the erae. (only when you hold them, but not after release)

Hope this can be fixed easily ;)


I've added a small video to show the problem.


Hey Gaetan,

Thanks for all the files.

There seems to be a small bug with the latest software version regarding Buttons assigned to Notes, can you confirm if you can use Buttons with Latched Control Changes in the meantime, and if it produces the same result?

We are working on fixing this issue for the next update!


It's been 2 months, what's the progress on this bugfix?

Best regards,

Login or Signup to post a comment