Start a new topic

dont see Midi mpe option on preferences?

i also dont see erae touch in control surface drop down? probs doing something wrong but totally stumped

Hey Dan!

No worries, we all stump sometimes! This is a free space for all questions.

Responding to your question, we have a whole article for setting up your ERAE on Ableton:

Make sure to copy the script to your folder, as indicated in the article whether using Mac or PC!


hi there! yes i have followed that down to the script folder.

still just not there :(

not to cause confusion, the right on that image is your tutorial page!

I am on pc if it helps, have tried unplugging/restarting computer etc. still only one Port shows

hi guys.. still.. its not showing up and am unable to use the device?

Dan.. I feel for you bro. NO response is quite a terrible thing. hopefully these guys at Embodme can pick up their game on customer service. Looks to be pretty shit at the moment


Hey Dan,

Are you using the last firmware available here ?

You can see the firmware version of your Erae when it is connected to the Erae Lab. Click on the gear icon in the upper right corner of the Erae Lab, under ERAE Firmware you can see the version of the Erae Touch. You can update the Erae Touch from this tab, just make sure you have closed all DAW or midi software before.

After updating it, unplug and plug again both usb and power cable should be enough to the PC to recognize MPE and non-MPE devices.

If it was already updated or if after doing the previous instruction both devices still doesn't appear, you can contact me at to plan a video call this week to see in detail this problem in your configuration.


Login or Signup to post a comment